Solved

Protected Applications and Alt-key processing

  • 14 December 2012
  • 32 replies
  • 183 views

Badge +3
I've been struggling with this for quite a while and just saw the issue of Firefox crashing on launch correlated with Protected Applications.  Yeah I've had that happening for a couple weeks and blaming Win8.  But something I've been struggling with even longer is Opera (another protected application) and using the simple and common Alt-D keystroke that simply positions the focus to the address field.  Then I had the same problem in Quicken 2012, but only on one screen where I happen to use the Alt key as a short cut.  So Webroot Protection (identity) seems to be a common link.  Disabling all of these applications from "Protected" seems to resolve the problems.
 
What's going on specifically is this.  In Opera, when I press Alt-D, focus initially shifts to the address field (as you'd expect it to) but then when I release the Alt key (in slow motion, one hits Alt, then D, then releases D, then releases Alt), focus shifts to the File menu item (as in File, Edit, etc)...it doesn't cause the menu to drop down, but highlights File and then I need to hit escape to clear it.  So it's as if the Alt-key "KeyUp" event is being sent again.  I'm in their beta program and can't tell you how many times I reported this and now feel more than a little foolish.  Also, pressing Alt and any of the File menu shortcuts sometimes works and sometimes does nothing...disabling Weboot Protection causes Opera to work as it should.
 
I'm running Win8x64, Opera 32-bit (current version) where the problem is easy to recreate.  I guess consider this a bug report...?
 
Thanks!
 
PS - I'm on the weboot essentials still as I was notified I'd be updated automatically to complete, but that has yet to happen.
icon

Best answer by JimM 13 February 2013, 20:41

View original

32 replies

Badge +3
An additional clarification, I had these same issues under Win7x64 (with the exception of Firefox crashing, I don't think I added that one to the protection list until later).  Also, I've noticed the computer is generally more responsive now with the Identity Protection feature disabled...granted this is difficult to quantify.  But if nothing else I maybe this is helpful to Webroot developers and other users that might be running into flakey issues.  Or even better, maybe someone can provide me with a fix.  :)
Userlevel 7
As a beta user for that software, you will be one of the first Webroot users to see files related to that software, and Webroot will likely be treating those new files with a higher degree of suspicion than is probably necessary just by virtue of them being new files.  That is one of the things mentioned in this related article.
 
It would be best to go through support with this concern in order for our threat researchers to make any determinations necessary before further troubleshooting if any is needed.
Badge +3
OK thanks. I filed a ticket pointing back to this thread.
Badge +3
Here's a short update now that there was a new version of WSA released.  The behavior has changed for the better.  No longer can I reproduce the issue with <Alt-D> not going to the address bar in Opera.  However, if the address bar does not have focus and I switch to a different program (calc.exe for instance) and then flip back to opera, I have to press <Alt-D> two times for it to be recognized (the first sequence seems to be ignored).
 
Removing Opera from programs to monitor under the Identity Control program list and Allowing it under System Control program list have no affect.  Disabling identity control DOES solve the issue.  I didn't retest in Quicken as it's more difficult to replicate and much less an annoyance.
Userlevel 7
The issue in which an initial keypress appears to be blocked is being investigated by development and will likely be resolved soon in a forthcoming build. 🙂
Badge +3
Yeah I agree.  Further testing today here seems to be consistent with an initial keypress being blocked.  Sometimes when I'm surfing I just think "did I miss the key".  Today I reproduced that problem (outside of Alt-key stuff).  Was on a web page search and toggled away and then back and starting typing a word and the first letter was indeed missing.  Reproduced it.  Not me!  :)
 
Was originally thinking this was related to Alt-key shortcuts but then thought I saw it with Ctrl-C and now others.  Thanks for the update!  I don't have time at the moment to capture logs for you guys as reqeusted...maybe it can be resolved without.
@gpb500 Thank you for posting this.  I noticed it eary last week with Chrome (ALT+D as well).  I assumed it was a bug in Chrome (and even went as far as opening a bug with them).
 
SecureAnywhere wasn't even on my radar until this morning when I had the same problem with an instance Notepad using ALT+F, S and ALT+O, W.
 
I unfortunately don't have permission on my machine to disable SecureAnywhere temporarily to rule it out.  Hopefully this gets resolved, it sounds like they've been able to replicate it?
Badge +3
@gpb500 Thank you for posting this.
 
No problem, and I appreciate you posting a confirmation as well.  It's good to hear it's not just my system(s).  I had considered doing a clean reload of Win8 but I've had this as an on-going problem for quite a while.  Same thing happens on my notebook which is running win7x86.  I did test on a 2nd notebook and had found results to be inconsistent/inconclusive.  Never used chrome but that is interesting to hear.  Sounds like Mike and the WSA guys might be onto something.
Badge +3
Oops. Meant to type JIM not Mike. Sorry Jim...guess I can't blame WSA for that. 😞
Userlevel 7
Haha, well that's ok.  :catembarrassed:  To be accurate, this issue was actually being investigated by Joe (V.P. of Development).  It appears to be resolved as of 8.0.2.92.  Does it appear to be resolved for you with that build?
Badge +3
I haven't received 92 yet, still 85; when I click update I get the standard message nothing needs to be updated.  Will test when it gets here.  Thanks!
Badge +3
Oh BTW, I was finally updated to "Complete" but we're in the WSA-ISP forum. Still says I'm using the newest...maybe "Complete" hasn't been set up yet. Thx.
Still in 8.0.2.85 as well. Will reply when I see .92 and can confirm that the issue no longer exists. Thanks for the quick turnaround.
Userlevel 7
Badge +56
If you want to update sooner go in your My Webroot Account and go to the upper right and click on your email address and click on Downloads and download and install over top. ;)
 
TH
Badge +3
Helix...thanks for that.
 
Regarding the conflict with WSA and Opera, it's now a bit worse.  Now when I hit <Alt-D> it positions focus to the address field and selects the URL if one is typed in there but then sets focus on the File menu (as if I pressed Alt-D followed by Alt (no other key) and release).  I would need to press <Esc> to get off of the File menu.  If I press Alt-D a second time in succession, the focus shifts away from the File menu and is positioned only in the Address field.  That's odd behavior...haven't seen that before.  Disabling Identity Shield resolves the problem entirely.
 
Thanks.
Userlevel 7
This issue reproduces for me.  I'll notify development. Thanks for the report!
 
*I noticed I was on .85 the first time I reproduced the issue, so there was some extra weirdness I've edited out of this reply to avoid confusion.  Updating to .92 still reproduces the issue as described though, so development is still going to be alerted.
Userlevel 7
Badge +56
I do and also in Firefox but IE9 it selects the first character.
 
TH
Badge +3
Even more weirdness. I went to reply (not quick reply) and tested there and Alt-D was selecting areas of the web page with blue boxes. I had to back out of that screen to reply So no, not seeing where the address field is selected WITHOUT the first character. For me, Address is fully selected and File is highlighted but the menu under File does not drop. Like pressing Alt-D + Alt. Thx.
This appears fixed in 8.0.2.96.  I'll let you know if I see otherwise in the coming hours.
 
Thanks!
Badge +3
Depends what you mean by "this". It didn't fix anything in Opera that I can tell.
Yea, spoke too soon. I usually have about 20 tabs open in Chrome at any given time. I only had 2 at the time when I was testing.

I logged into our conference room machine for my daily meeting and ran into the same problem there. I checked the version of SecureAnywhere on that machine and it was also already updated to .96.

=[
Userlevel 7
The issue in which usage of Alt+D bringing up Opera's file menu is still under investigation.  8.0.2.96 contained a quick fix for unnecessary firewall prompts but did not address this issue.
Badge +3
Jim, Any updates on this issue? Thanks in advance.
Userlevel 7
The only update we have on this case at the moment is that this behavior was found to reproduce in Chrome as well. Investigation has been handed over to development, who are still looking at it. We'll probably start to see more activity with the holidays behind us.
Badge +3
Jim, ran into another odd situation with Identity Protection yesterday.  Was using on my notebook (Win7x86) and was using VueMinder calendar and it needed authorization to access my Google calendar.  So it launched the appropriate google web page in my default browser (opera in my case) and I was able to log in to google to get that magic string of characters for authorizing.  All I needed to do was copy and paste the string from the opera page to the VueMinder dialog...a standard textbox as far as I could tell.  I could not paste it (right click - paste or ctrl-v or even using the paste button they provide) .  I verified the copy was working by pasting it to another field in opera...but pasting would not happen into VueMinder.  When I disabled Identity Protection it worked fine.  Maybe I have something set wrong...I don't know.  Thx.
 
PS - I'm on the Complete version now.
 
 

Reply