Solved

Protected Applications and Alt-key processing

  • 14 December 2012
  • 32 replies
  • 183 views

Badge +3
I've been struggling with this for quite a while and just saw the issue of Firefox crashing on launch correlated with Protected Applications.  Yeah I've had that happening for a couple weeks and blaming Win8.  But something I've been struggling with even longer is Opera (another protected application) and using the simple and common Alt-D keystroke that simply positions the focus to the address field.  Then I had the same problem in Quicken 2012, but only on one screen where I happen to use the Alt key as a short cut.  So Webroot Protection (identity) seems to be a common link.  Disabling all of these applications from "Protected" seems to resolve the problems.
 
What's going on specifically is this.  In Opera, when I press Alt-D, focus initially shifts to the address field (as you'd expect it to) but then when I release the Alt key (in slow motion, one hits Alt, then D, then releases D, then releases Alt), focus shifts to the File menu item (as in File, Edit, etc)...it doesn't cause the menu to drop down, but highlights File and then I need to hit escape to clear it.  So it's as if the Alt-key "KeyUp" event is being sent again.  I'm in their beta program and can't tell you how many times I reported this and now feel more than a little foolish.  Also, pressing Alt and any of the File menu shortcuts sometimes works and sometimes does nothing...disabling Weboot Protection causes Opera to work as it should.
 
I'm running Win8x64, Opera 32-bit (current version) where the problem is easy to recreate.  I guess consider this a bug report...?
 
Thanks!
 
PS - I'm on the weboot essentials still as I was notified I'd be updated automatically to complete, but that has yet to happen.
icon

Best answer by JimM 13 February 2013, 20:41

View original

32 replies

Userlevel 7
In this newer case, I would first suggest seeing if VueMinder is set to an Allow status or not in your Protected Applications settings. (Identity & Privacy > View/Edit Protected Applications > Allow)

If you were to set it to Allow and restart VueMinder and Opera, there is a good chance the issue should be resolved. If not, please reply back letting us know otherwise.
Badge +3
Was able to recreate the problem easily on my desktop too.  So checked the status of the program and it was in"Deny" mode (couldn't paste).  Switched to "Protect"...and now is fine.  Was thinking why is it in "Deny" mode.  Actually when I did a recent upgrade of vueminder, WRSA complained about this file...here are the details.
 
c:windowsinstallermsib7a2.tmp
 
That file does not exist in that folder...but is listed in my quarantine.  Figured false positive...?  Should I submit this to you guys for analysis?  It's happened a couple times already.  Thanks!
Userlevel 7
Yes, please.  Reporting false positives though the support system is always advisable.  It will help us get that taken care of quickly for everyone who has the problem, all at once.
Userlevel 7
The Alt+D issue in Opera has been fixed as of 8.0.2.105.  🙂
Out of curiosity, is the issue also confirmed as resolved in Chrome?

My IT department graciously disabled the features of SecureAnywhere that were causing the issue for me in early January so I can't confirm it on my end without asking them to re-enable the features, which I'm reluctant to do.

Thanks!
Badge +3
Super. Will test and post if I see any issues. Thanks!
Userlevel 7
Langdon, that's a good question.  I asked the same question over in this other thread.  To be positive, I'd like to see a report back from the field, though I strongly suspect it's probably resolved in both browsers.  I just checked for you, and it works on my own test box, so it's most likely safe to say it's fixed. 😉

Reply