I am new to VPN and in the USA.


Userlevel 3
 I just did a Google search and I am getting international results. Can I fix that?

15 replies

Userlevel 6
Badge +11
If you connect to an international server then as far as Google or anyone else is concerned, you are located in that country whilst doing the search. The IP address is allocated to that country and that is where the traffic is coming from. In some cases this might be desirable, if it isn't your best option is to connect to one of the two locations in the United States. This will still protect your privacy whilst returning more US relevant results.
 
As you will still appear to be in a location other than your actual location, you may need to use location as part of any search criteria if you are looking for a local business or attraction. For example if you wanted to search for "Central Perk" in New York but were connected to United States West you might get higher results for a "Central Perk" in San Franscisco as it appears to be closer to you than the one in New York.
 
To work around this try searching for "Central Perk New York".
Userlevel 3
I am not connected to an international server.
I am connected to USA West. When I open my Google search page, it is in a forign language and has an option to transulate into English in the right of the screen.
I should not be getting forign websites from a US server.
Please help me resolve this.
Userlevel 6
Badge +11
This sounds a bit odd - do you know which language you are getting results in? Does this happen when you are not connected to the Webroot WiFi Security VPN?
 
Our awesome support team will be able to help you, but there are a couple of things I can think of you can try yourself-
 
  1. Double check you are connected to the right server location following the instructions in this knowledge base article.
  2. Whilst connected to Webroot WiFi Security VPN visit What Is My IP and look at their geolocation section - you should have seen this appear to move from the area of your home, but it should still be in the United States. If it isn't, definitely raise a ticket with us via the support page.
  3. Check the URL at the top of the Google page you are using - this should be google.com in the United States, not google.es or google.fr for example. That said, I tried Google.fr whilst connected to the French VPN location and the results were relevant to France but Google itself still used the English language to list them. This doesn't sound like your problem.
  4. Check the language settings of your browser. Here are some instructions from the browser companies websites-[list]
  5. Google Chrome (see Change the language of your Chrome browser) - https://support.google.com/chrome/answer/173424
  6. Mozilla Firefox https://support.mozilla.org/en-US/kb/settings-for-web-content-pop-ups-fonts-languages
Edge, Internet Explorer and Safari use the language set for the computer.[/list]
Userlevel 3
When connected to USA West, it shows the following geolocation.
City: New York City
State: New York
Country: United States
When connected to USA East, it shows the following geolocation.
City: New York City
State: New York
Country: United States
No matter how many times I switch between West coast and east coast, it shows east coast.
I think this was likely the probelm before, when I was selecting West coast, I was actually still connected to another country. What is causing this?
 
Note below PIC of me connected to US West but the server is in New York.
 
It I click on "automatic", Mexico is selected. Shown below as..
City: Guadalajara
State: Jalisco
Country: Mexico
I think this is the forigon language I was getting.
I then disconnest and select US West coast. Shown below as..
City: Garden City
State: New York
Country: United States
 
West coast is not being selected proberly and when switched to "automatic" I shouldn't be sent to another country where my browser is in a forign language.
 


Userlevel 7
Badge +55

@Masterblaster73 wrote:
When connected to USA West, it shows the following geolocation.
City: New York City
State: New York
Country: United States
When connected to USA East, it shows the following geolocation.
City: New York City
State: New York
Country: United States
No matter how many times I switch between West coast and east coast, it shows east coast.
I think this was likely the probelm before, when I was selecting West coast, I was actually still connected to another country. What is causing this?
 
Note below PIC of me connected to US West but the server is in New York.
 


We have seen this during Beta Testing so it would be nice to know why US East and West comes from the same IP server in New York most times?
Userlevel 3
West coast is not being selected proberly and when switched to "automatic" I shouldn't be sent to another country where my browser is in a forign language. I also believe before when I had it set to automatic I was connected to Mexico. Then when I switch back to USA West it never switched back that's why I had the foreign language on my browser.
Userlevel 7
Badge +55

@Masterblaster73 wrote:
West coast is not being selected proberly and when switched to "automatic" I shouldn't be sent to another country where my browser is in a forign language. I also believe before when I had it set to automatic I was connected to Mexico. Then when I switch back to USA West it never switched back that's why I had the foreign language on my browser.

Again have a look here: https://community.webroot.com/t5/Webroot-WiFi-Security-KB/Changing-the-WiFi-Security-Server-Location/ta-p/326420
Userlevel 3
I understand that and that is exactly what I am doing. Are my posts not clear?
I manually (not automatic) choose US West server. See my pic. It stayed on US East. Then if I switch to "auto" it should not go to a forign country in another language.
Thanks for your help but I think what I am doing is correctly. 
Userlevel 7
Badge +55

@Masterblaster73 wrote:
I understand that and that is exactly what I am doing. Are my posts not clear?

Just double checking nothing more.
Userlevel 3
Thanks for your help. I didn't mean to sound short.
It suprises this VPN program is beheaving like this. Problems like this should be flushed out in beta testing. Not is a final release.
Userlevel 7
Badge +55
@Masterblaster73 you can ask questions here in about 30 minutes! https://community.webroot.com/t5/Announcements/Upcoming-Webroot-WiFi-Security-Q-amp-A/m-p/331914
Userlevel 3
Got it. Thank you. I posted there also.
Userlevel 6
Badge +11
Client behaviour like this isn't in my area of expertise, but I have referred your issues onwards. The only comment I can make is that automatic may be completely agnostic to language but only look at metrics like load on servers and latency. It may be that Mexico (if indeed it was Mexico) was being chosen because in strict technical terms it gave the best user experience at that point in time - that is pure speculation though.
 
If you always want a US based server in the short term I would suggest manually selecting either US West or East as your location.
Userlevel 3
I really wish you woulkd read my post completely.
My West coast server is not being selected proberly (it shows West coast but the server location is actually East coast) and when switch to "automatic" I am sent to another country (Mexico) where my browser is in a forign language. Then when I try to switch back to West cost manually, it stays on the Mexico server in Spanish.
Automatic should never send you to another country in another language.
 
Right now I should be on US West but Google is asking me the following:
Looking for results in English?
Change to English
Stay in Iñlisçe
Language settings
 
I have the server manually set to US West and when I open my Google browser, It is clearly in another language asking me if I want to transulate in English. It is clearly not switching to US West.
 
Userlevel 6
Badge +11
@Masterblaster73 Rest assured I have read your posts and have referred the issues you've raised to people who can better deal with them. The only point I am trying to make is that automatic location may simply look at the location with lowest latency for the user and/or lowest load, and may not take language into account at all.
 
I have raised all three of your issues internally with the appropriate people.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept or continue browsing you agree to our cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings