Samsung Universal Print Driver won't install

Since I upgraded from Windows 8 to 8.1 I've been unable to use my printer.  I've downloaded the Universal Driver for 8.1 from Samsung but it won't install.  The installation recognizes my printer but from there it stops and I get a message saying that it can't complete the installation .  I've tried disabling my firewall but it doesn't make a difference.  Does anyone have suggestions?

11 replies

Userlevel 7
Hi bizzibee
In case I have not already welcomed to the Community Fora...Welcome...
I take it that WSA has not alerted you to a threat but just to be on the safe side check in Quarantine to see if there are any Samsung related files held there.
If not then I would suggest that you check to see if the installer has been blocked by WSA.  This should be checked under Control Active Processes (quickest way to get there is to right click on the sys tray icon and select the relevant entry)...once in the relevant panel check the list of files/apps for anything remotely looking like an installer or Samsung-related and see if the 'Blocked' radio is checked...if so then this should be your issue.  If you are confident that this is indeed a legitimate app/file then switch the setting to 'Allow' and try installing again.
The other place that WSA may be blocking the installer is Block/Allow Files (click on the gear/cog to the right of the PC Security tab on the main panel, and then from there select the tab marked 'Block/Allow Files'.  In the list of files/apps displayed again look for for anything remotely looking like an installer or Samsung-related and see which radio is checked...if 'Blocked' then switch the setting to 'Monitor'.  If you are certain that the file/app is legit then you can set it to 'Allow' but I always advise 'Monitor' in these cases...WSA will allow the file to run but will journal its activity so that if found to be a nasty the actions can be rolled back.
OK, enough from me for now...give that a try and see if it helps...and post back on how you are getting on.
Hi Baldrick,
I've checked all of the places in WSA that you suggested and I find nothing related to Samsung.  It must be a problem with my computer.  Do you have any suggestions that I might try?
Userlevel 7
Badge +51
Hello bizzibee and Welcome to the Webroot Community Forums!
Check the availability of records in WSA:
C: Users username AppData Local Temp  
Thank you
Userlevel 7
Hi Petr
Would you able to elaborate a little as to your last post?  I am not following as to what you are suggesting in it...or why.
It would be useful to understand in case it can help.
Userlevel 7
Badge +51
Temporary directory is a directory used to hold temporary files in this case, necessary for installation.
they can be locked,  may interfere with the installation

Userlevel 7
Thanks, but have never come across anything locking that folder or it's contents.  Have checked on my system, tried a few installs (which I have then rolled back...?
What are you thinking might be locking it/preventing installation?
I am not finding App Data.  Could this be the problem? 
Userlevel 7
Badge +51
Best to contact Webroot support:
Support Number: 1-866-612-4227
Support Ticket:
Try disabling the WSA.
Repeat installation
There is a blocking?
Userlevel 5
Submit a ticket or call the webroot support team.
Userlevel 7
Please be aware that support can only have a look to see if Webroot is blocking/stopping the installation. I would advise contacting Samsung in the mean time since it sounds like they may need a driver update. 
I have spent over 2 hours with Samsung.  They are no helpk, they just tell me it's an issue with my computer.