Solved

delta-home sweet-page

  • 19 March 2014
  • 3 replies
  • 1214 views

New on the forum and glad to join!
 
I have Windows 8.1. I have been "infected" by the delta-home and sweet-page search pages which appear respectively on Chrome and Internet Explorer respectively at startup of the browsers (apparently from the Conduit company). These home pages appear at startup independently of the startup pages defined in the browsers.  It seems very difficult to get read of them (even by setting up other search pages and removing the delta-home and sweet-page programs).  These search pages are not recognized as malware by Webroot or any other AV I have been using. I think this is unfortunate because this Conduit softwares are a real pain.  Any solution ?
icon

Best answer by Petrovic 19 March 2014, 07:43

View original

3 replies

Userlevel 7
Badge +51
Hello AF51 and Welcome to the Webroot Community Forums!
 
When the Add/Remove Programs or the Uninstall a Program screen is displayed, scroll through the list of currently installed programs and remove eSave Security ControlGoPlayerDesk 365,Delta Chrome Toolbar, Delta toolbar, Yontoo, BrowserProtect, and Mixi.DJ and any other recently installed application. It won't be listed as delta-homes.com in the currently installed programs list. So, either look for applications mentioned here or try to remember what software you installed recently. It's probably the culprit
 If you are having issues while trying to uninstall the program, you can use Revo Uninstaller
 
Remove delta-homes.com from Google Chrome:
1. Click on Customize and control Google Chrome icon. Select Settings.
2. Click Set pages under the On startup.
Remove delta-homes.com by clicking the "X" mark as shown in the image below.
3. Click Show Home button under Appearance. Then click Change.
4. Click Manager search engines button under Search.
Select Google or any other search engine you like from the list and make it your default search engine provider.
Select delta-homes.com from the list and remove it by clicking the "X" mark as shown in the image below.
 
5. Right-click the Google Chrome shortcut you are using to open your web browser and select Properties.
6. Select Shortcut tab and remove delta-homes.com from the Target field and click OK to save changes. Basically, there should be only the path to Chrome executable file. Nothing more.



 
Remove delta-homes.com from Mozilla Firefox:

1. In the URL address bar, type about:config and hit Enter.
In the search filter at the top, type: delta-homes
Now, you should see all the preferences that were changed by delta-homes. Right-click on the preference and selectReset to restore default value. Reset all found preferences!
4. Right-click the Mozilla Firefox shortcut you are using to open your web browser and select Properties.
5. Select Shortcut tab and remove delta-homes.com from the Target field and click OK to save changes. Basically, there should be only the path to Firefox executable file.
 
Remove delta-homes.com in Internet Explorer:

1. Open Internet Explorer. Go to Tools ? Manage Add-ons.
2. Select Search Providers. First of all, choose Live Search search engine and make it your default web search provider (Set as default).
3. Select delta-homes.com and click Remove to remove it. Close the window.
4. Right-click the Internet Explorer shortcut you are using to open your web browser and select Properties.
5. Select Shortcut tab and remove delta-homes.com from the Target field and click OK to save changes. Basically, there should be only the path to Internet Explorer executable file.
 
6. Finally, go to Tools ? Internet Options and restore your home page to default.
 
&
Read this thread:
Virus Removal Options
 
How to Remove Potentially Unwanted Applications
 
 
Thank you
Best regard, Petr.
Thank you Petrovic !
 
Very helpful. What helped is to redefine the shortcut target of the brother.
 
Best,
 
AF51
Userlevel 7
Badge +51
Thanks
Please feel free to ask any further questions you might have.
 
Best regard, Petr.

Reply