Question

Wireless printer not working when connected to VPN

  • 10 April 2019
  • 6 replies
  • 1300 views

Is there a way to set up the Webroot VPN that allows printing to my wireless printer? At this point, in order to print I need to disconnect the VPN. I would prefer to have a seamless way to print while remaining connected. Do you know if this is possible? I previously tried ExpressVPN and they had a setting that got around the wireless printer issue.

6 replies

Userlevel 7
Hello @jelliottf Welcome to the Webroot Community Forum. ☺
Sorry you are having trouble connecting to your wireless printer using Webroot's VPN. I'll ping our VIP Developer @pstonethompson to see if he can come up with a solution to this problem.

Dave.
Hi @jelliottf ,

I'm not hugely familiar with Webroot's VPN, I have run it in the past. But, You could try adding your WiFi network as a 'Trusted' WiFI network and see if that helps. To do this, please do the following...

Open the app and click on the three lines in the upper-right.



Then, under the "Connections" tab, check the box for "Enable trusted WiFi Networks' and click the '+' to add your network to the 'Trusted' list. Be sure to click 'Apply' when done. ;)





If you're still having issues then you can either wait for a reply from @pstonethompson or submit a support ticket to Webroot and see if they can assist.

Hope this info helps,
Userlevel 6
Badge +14
@jelliottf I have asked the team responsible for the VPN client and this is their answer-

I assume we are talking about Windows app. It does allow to print on the wireless printers in the local network while connected to the VPN, but there might be some weird edge case related to the Kill Switch which breaks printing.
I'd suggest to ask user to turn off the Kill Switch, connect to the VPN and then try to print. If it works this way, I'd suggest to ask user to turn the Kill Switch back on, reproduce the issue and provide the logs. In this case the most important ones are netfilter.access.log and service.log. The ip address of the wireless printer will also be good to know.


Can you confirm the operating system of the computer you are having problems with, if the printer is on the local network and how it is connected? The first two parts of the IP address of the printer (e.g. 10.0. or 192.168.) would be enough to tell if it was a local IP address and would not identify your location (please don't post a full IP address on the forums, especially if it doesn't start with 10 or 192 - if in doubt DM me).

Can you also see how you get on with the Kill Switch as described above? If the kill switch toggle fixes it would you be kind enough to send me or the support team those logs citing this thread?

Many thanks and apologies for the inconvenience.
Badge +2
I also have this problem. I have always been able to print to my HP Officejet Pro 8600 Plus via WiFi from my desktop (Dell XPS 8700 Intel i7-4790 CPU @ 3.60GHz 16.0 GB RAM, Windows 10 version 1903 64-bit op system), laptop (HP Pavilion Intel i5-7200U CPU @ 2.50GHz 12.0 GB RAM, Windows 10 version 1809 64-bit op system, and smartphone (Samsung Galaxy S8+). However, when I turned on Webroot WiFi Security on all 3, none of them would print. When I disconnected them, they all printed. I do have my Trusted WifI Network selected for all 3. Turning off the Kill Switch had no effect. In order to print, I must disconnect Webroot WiFi Security. I have two netfilter.access.logs and one service.log available to email to you if you need them.
Userlevel 6
Badge +14
@bobonweb Apologies for the inconvenience here. I have Direct Messaged you.
Badge
I am running a Dell Insprion 7773 laptop
https://
https://

On a Linksys WRT 1900AT router

Wireless to a Brother MFC-J4510W printer

When I installed the Webroot WiFi Security VPN I was unable to use the wireless feature at all.

Per other suggestions on this thread I simply turned off the Kill Switch and it works just fine.

Note to Webroot: If this has been or will be fixed in future versions it would be great to give everyone a "Heads UP".

Reply