Solved

Webroot would not install on windows 10, nothing happens when installer is double clicked

  • 15 March 2018
  • 2 replies
  • 1903 views

Hi,
 
I'm trying to install webroot, when I double click the installer, nothing happens. I've looked into the list of installed programs, and webroot is nowhere to be found, therefore there's nothing to uninstall.
 
I've tried the installer 9.0.19.43 downloaded from other threads and had no luck. My operating system is Windows 10.
 
Thank you
icon

Best answer by TripleHelix 19 September 2018, 23:21

Hello @ and Welcome to the Webroot Community!
 
Try this below!
 
Please follow the steps below closely in terms of installing WSA on the target system/machine!
 
  • Make sure you have a copy of your 20 Character Alphanumeric Keycode! Example: SA69-AAAA-A783-DE78-XXXX
  • Be sure you have or add your Keycode to your Online Console: Webroot SecureAnywhere Online Console
  • KEEP the computer online during the install to make sure it works correctly
  • Download a Copy Here (Best Buy Geek Squad Subscription PC users click HERE). Let us know if it is the Mac version you need
  • Install with the new installer, entering your Keycode when prompted to do so in the install process
  • Let it finish it's install scan
  • Reboot 
Thanks,
View original

2 replies

I have recently brought HP Spectre x360 laptop with windows 10 OS, then I tried to install Webroot in my new laptop but it is not installed I thought it was my laptop issue, so I contacted ~snip Link Removed~ PTD, but they told me my laptop is perfect then Can anyone tell me why this issue is arising and how it can be resolved.
Userlevel 7
Badge +55
Hello @ and Welcome to the Webroot Community!
 
Try this below!
 
Please follow the steps below closely in terms of installing WSA on the target system/machine!
 
  • Make sure you have a copy of your 20 Character Alphanumeric Keycode! Example: SA69-AAAA-A783-DE78-XXXX
  • Be sure you have or add your Keycode to your Online Console: Webroot SecureAnywhere Online Console
  • KEEP the computer online during the install to make sure it works correctly
  • Download a Copy Here (Best Buy Geek Squad Subscription PC users click HERE). Let us know if it is the Mac version you need
  • Install with the new installer, entering your Keycode when prompted to do so in the install process
  • Let it finish it's install scan
  • Reboot 
Thanks,

Reply