Question

Subscription Purchase failed

  • 24 May 2020
  • 9 replies
  • 259 views

While purchasing the subscription, I have received errors for both Paypal and card payments, and then the subscription failed. I tried it once again and it returned with the same errors. Twice my money got deducted, but not subscribed.

I have 2 transaction proofs. For both the transactions money has been deducted from my bank account to Webroot security.

 

It has been more than 72 hours and the money has not reverted back.

Please help me to get the subscription for one time the amount got deducted and refund the duplicate amount that has been deducted.


9 replies

Userlevel 7
Badge +51

Hi @joebalaji 

Sorry for the delay you are having, most of us on here are just volunteers but I will ping a couple of the Webroot team who will hopefully sort it out or get things moving for you.

@freydrew  @khumphrey 

Hi @joebalaji 

Sorry for the delay you are having, most of us on here are just volunteers but I will pink a couple of the Webroot team who will hopefully sort it out or get things moving for you.

@freydrew  @khumphrey 

Thank you @Jasper_The_Rasper

I hope they provide a solution for subscription and to get my money back. 

Hi @joebalaji 

Sorry for the delay you are having, most of us on here are just volunteers but I will pink a couple of the Webroot team who will hopefully sort it out or get things moving for you.

@freydrew  @khumphrey 


Hey @Jasper_The_Rasper unknowingly I clicked solve button instead of liking your comment. Please help me with this.

Userlevel 7
Badge +51

I have marked it as unsolved for you now @joebalaji  and you do not need to do anything now until either @freydrew or @khumphrey have replied to you.

Userlevel 7
Badge +17

@joebalaji ,

Have you tried contacting our SUPPORT TEAM ? I’m unable to see information regarding payment processing so you will have to go through customer support to get something like this resolved. I would recommend calling as that will likely be quicker and easier for them to confirm your identity. 

 

Please let me know if you have any trouble. Thanks!

-Keenan

@joebalaji ,

Have you tried contacting our SUPPORT TEAM ? I’m unable to see information regarding payment processing so you will have to go through customer support to get something like this resolved. I would recommend calling as that will likely be quicker and easier for them to confirm your identity. 

 

Please let me know if you have any trouble. Thanks!

-Keenan

Hi Keenan,
 

I have raised a ticket about the same last week. I didn't get any response from the support. Also, I have tried to contact the toll-free numbers and for me, it says the numbers aren't valid as I'm from India. The money is not refunded to my bank account too. I can attach the transaction details to webroot if needed. Please help me with this.

@joebalaji ,

Have you tried contacting our SUPPORT TEAM ? I’m unable to see information regarding payment processing so you will have to go through customer support to get something like this resolved. I would recommend calling as that will likely be quicker and easier for them to confirm your identity. 

 

Please let me know if you have any trouble. Thanks!

-Keenan

Hi Keenan,
 

I have raised a ticket about the same last week. I didn't get any response from the support. Also, I have tried to contact the toll-free numbers and for me, it says the numbers aren't valid as I'm from India. The money is not refunded to my bank account too. I can attach the transaction details to webroot if needed. Please help me with this.

Hi @khumphrey ,

I still didn't receive my money back or the issue is not resolved. Is this the way webroot steals money? Because I didn't get response from support for more than 2 weeks now. The transaction showed error, it didn't get fail or success. But still webroot took money from my account. And still I didn't get subscription either. When I have contacted bank, they have mentioned that the transaction has made by webroot showing it as success  and debited 2 times. How can we trust this product any more when they steal through URL like an hacker? The product is losing a customer who is using it for years. This seems like Webroot is doing a Cross-Site Scriptingattack on customers and stealing money from their account. I have screenshot of URL, purchase error and transaction to Webroot company. We root cannot deny this incident. If I am not getting this resolved, I'm sure I will make this issue known to everyone as this company is cheating customers.

Userlevel 7
Badge +17

@joebalaji ,

I’m sorry that support has not gotten back to you yet - can you please private message me the email associated with your webroot account? I’ll check in with support for you.

 

Thanks,

Keenan

@joebalaji ,

I’m sorry that support has not gotten back to you yet - can you please private message me the email associated with your webroot account? I’ll check in with support for you.

 

Thanks,

Keenan

Sure, please check your inbox.

Reply