Just updated my install and keep getting Error(UCR2): Invalid security code credentials

  • 19 May 2015
  • 4 replies

Last year I purchased Best Buy / Geek Squad version of webroot.  This year I purchased a 5 computer version online.  Just installed, which seems to have worked, but  when I try to resolve the Activate your account, and enter secruity code numbers, I get an error code - Error(UCR2): Invalid security code credentials    Help , I want to get on with my life.

4 replies

Good morning,
What you are encountering is a very common occurrence. What it appears is you have the "Geek Squad" flavor of Webroot installed and you are attempting to use a Commercial version of Webroot Key. As you can see they don't play well together. What you need to do is uninstall the Geek SQuad version of Webroot and download and install the appropriate version from here:
After you install enter the new key you purchased and poof, all will work as expected.
Any other questions or problems please feel free to come back and we will help as best we can.
Have a great day and a better tomorrow.
Userlevel 7
Badge +56
Hello and Welcome to the Webroot Community!
As Andy suggested here is the Dowload link for all versions1 installer:
Standard Download Link PC:
Daniel 😉
Thanks for suggestions. I un-installed Geek Squad version, uploaded / installed new version.  Appears to be installed properly.  Still have the blue - Need to Activate screen - I add the info, get the email link - click it - follow instructions to use the Security Code I provided and it STILL shows the same error code.     Any more suggestions are welcomed.  
I noticed that as I started to put the information into the field, a popup says to enter password - this is very confusing
Userlevel 7
Badge +56
Have you setup your online console? If not please do so and if you already did please Submit a Support Ticket and they will help you get it sorted!
Daniel ;)