webroot & firefox 40

Userlevel 7
Badge +37
Hi ,
I installed firefox 40 .
also webroot web filter is active , but show it have some problem .

Regards ,

71 replies

Userlevel 7
Badge +56
Ok we've got an update on this issue.  If the toolbarfix doesn't work for you, please contact our support team.  They have a manual workaround that they can do to fix this issue for you:
Edit:  There's now a self-service version of the procedure that you can follow here:
You can also still contact support if you'd like assistance getting that working.
Userlevel 7
If I may, David, I would ,like to add that the command:
"C:Program FilesWebrootWRSA.exe" –uninstall
should be run from a command prompt with elevated right, i.e., as an administrator.
If running pre-Windows 10 then just type cmd into the Start Menu search field and then right click on the search result to display a contect menu. From that select 'Run as administrator' and then enter the commandline in the command prompt that will have opened.
If running in Windows 10 right click on the Start Menu icon, and from the context menu displayed select 'Command Prompt (Admin)' and then enter the commandline in the command prompt that will have opened.
Hope that helps?
Regards, Baldrick
Userlevel 7
Yes, Webroot Support is aware of it.. they are the ones who have been able to work around it with a clean re-install.  You can submit a Trouble Ticket to have them take a look at your specific instance.
I do not blame you a bit for not wanting to try IE LOL.  Password Manager is working for it and Chrome, but I refuse to use IE at all these days.
Userlevel 7
Badge +56
Did you install this plugin?
It looks like LastPass put that up for some reason and we're trying to figure out what is going on.  Remove that one and try running the toolbarfix instead:
Userlevel 7
Badge +56
Ok here's what I have on the latest on this situation so far:
1. Toolbarfix works sometimes
2. Uninstall and reinstall works sometimes
3. Don't download the extension called Webroot Password Manager that was created by LastPass
3. We're working on getting this whole situation resolved and getting our proper extension signed by Firefox
Apologies for the mess in the meantime.
Userlevel 7
Personally I would not worry about it. The reason has been explained and I am sure that it will be resolved shortly once Webroot have managed to get their extension 'registered' / 'approved' by Mozilla...but of course, as Nic said...that may take some time as many software authors will be looking to get that done.
Userlevel 7
Currently I'm running version 40.0.2 and the extension is still not fixed yet.
Userlevel 7
That is a hassle, but it does happen once in a while.  (Really, not often, but we have seen it)
Please refer to the directions in this KB Article. It has directions for multiple versions of windows, so make sure to use the one for Windows VIsta.
Let us know how it goes please!
Userlevel 7
We have a couple of threads about this today.  A new post HERE, even though some have reported that toolbarfix.exe will not work, says he did manage it using that.  It looks like he manually removed the Password add-on from Firefox, and then ran the toolbarfix.
Might be worth a try as well
I know Webroot tried the toolbarfix.exe already, but maybe the manual removal of the add on would help.
?, thank you for the input above... and please do add any more you have.  TEAMWORK 🙂
Userlevel 7
Hi brithael49
As you will be aware from the information provided in this thread (and others) Webroot Support are aware of the is and working no doubt to wards a solution, but they are hampered by the fact that the issue is not one of Webroot's making but rather of Mozilla's and therefore there will be limited options.
Most of us are int he same boat as you and we just have to have patience whislt the solution is found.  If anyone needs railing against it is Mozilla for unilaterlaly taking the action that they have.
Regards, Baldrick
Userlevel 3
Badge +1
I hope the folks at Webroot will keep in mind the fact that more than 99% of their software users never visit these forums, and are simply mystified that the Webroot plug-in for Firefox has suddenly stopped working. Webroot really should notify users that they are aware of the issue and are working with Mozilla to resolve it.
In addition, whenever the issue is resolved, if getting the plug-in to work again requires specific intervention on the part of users, Webroot should notify all users of the steps they need to take. Otherwise, Webroot tech support will have to deal with upset users one at a time when they complain.
Lastly, and this is a personal aside, advising users to switch to an alternate browser isn't always an ideal solution. I won't switch to Internet Explorer, for a good number of reasons. I don't have Chrome installed simply because I strongly prefer Firefox. If I swiched to Chrome at this point, I'd also have to export and import all my bookmarks and change who-knows-how-many settings to getting Chrome to work the way I need it to. I'd rather live without the Webroot plug-in, hope that Mozilla and Webroot come up with a solution soon, and trust that Webroot will notify everybody as to what they'll need to do to get things back to normal again.
Userlevel 1
This is the instruction that I got today from Webroot.   The first part didn't work so I had to manually go into FF addons and remove the toolbar that wasn't working. But fingers crossed part 2 worked and I now have the Password Manager  working.
Thank you for contacting Webroot. In order to address the issue you are having with your Webroot SecureAnywhere Toolbar add-on, we would like to have you uninstall the toolbar and then reinstall it.

To uninstall and reinstall the Webroot toolbar, follow the instructions below.

**Part 1: Use a utility to uninstall the Webroot SecureAnywhere Toolbar**

1. Download and save the Webroot Toolbar utility to your Desktop using this link:


2. Double-click the "toolbarfix.exe" file to launch the installer.

3. Select "Uninstall the Webroot Toolbar," and then click "Start."

4. Follow the prompts until the following message appears: "Process Completed. Click Finish to exit."

5. Click Finish.

The toolbar should now be removed from Firefox, Internet Explorer, and Google Chrome. Keep in mind: you may need to restart your browser to see the change.

** Part 2: Use a utility to install the Webroot SecureAnywhere Toolbar **

1. Navigate back to your Desktop.

2. Double-click the "toolbarfix.exe" file to launch the installer.

3. Select "Repair/Install the Webroot Toolbar," and then click "Start."

4. Follow the prompts until the following message appears: "Installation was successful. Please open your Internet Browser(s) and be sure to Enable/Allow the Webroot Toolbar if prompted."

5. Click "OK," then click "Finish."

The toolbar should now be installed in Firefox, Internet Explorer, and Google Chrome. (These are the only browsers supported at this time.) Keep in mind: you may need to restart your browser to begin using the toolbar. The toolbar is represented by a small gray W icon next to your search bar. Click on the gray W to log in to the toolbar. Once you log into your account, the W icon will turn green.
Userlevel 4
Badge +12
Again uninstalled... and Reinstaled following previous instruction to the letter. Each occurence deletes toolbar in IE, FF and Chrome. And each reinstal instals it back to each. I even ran CC cleaner the final time to remove any redundant registry entries etc prior to reinstal.  It simply will not activate in FF.
At this point im done with the trial and error and will just hope an offical fix comes out quickly.
Userlevel 7
Badge +56
Sorry about that. I'll keep this thread updated as soon as I have more info.
Userlevel 7
Hello fernor1, welcome to the Community!
There is a problem currently with the 3.1.1 version of the Password Manager, and Webroot is very aware of it, and working to fix it.  It gets complicated in that the Password Manager is licensed from LastPass... so Webroot and LastPass must work together to figure out the issue, and THEN work with Mozilla as well to get the corrected version signed and allowed for FireFox.
I expect it will not be much longer before things are corrected, but until then there are a few options.
IE and Chrome both work just fine.  The issue is ONLY with FireFox.
If you have automatic update of add-ons enabled, you will want this turned OFF.
Some users have been able to go back to the previous version of the Password Manager.  If you have automatic update of add-ons enabled, you will want this turn off.  You can try either use of the toolbarfix.exe utility, or a clean re-install of WSA.  As soon as you do either of these, check the version of the Password Manager.
These methods have not worked for everyone, though most likely due to not disabling automatic updating of add-ons in Firefox is my guess. Here is a reply that details how one user did get back to the working 2.5 version, and it is working fine.
I hope this helps, and it should not be all that much longer before things are fixed and back to normal.
Userlevel 7
I believe that the change is due to the changes Firefox is working on to require that add-ons be 'signed' by them in order to work.  The whole point of signing is to verify that the add-on you download is the exact correct one from the provider, and that the add-on is indeed safe and not malware.
Since Webroot and Firefox are still working on getting a working AND signed Password Manager version 3.1.1, the browser will consider the add-on to be insecure simply by lack of being officially signed by Mozilla.
The Password Manger version 2.5.is quite safe, but since the version 2.5 never was, and never will be, signed by Mozilla, it will show that option.
I hope this helps!
Userlevel 3
Badge +1
Thanks for the explanation, David, that makes perfect sense.
I expect that, for the time being. any changes I see regarding WPM and Firefox will be part of a work in process. 😉.
Thanks for the update. Patience  I have, particualrly when I know what has transpired.
I posted the same problem earlier and after doing a firefox update, did the webroot toolbarfx and everything is now working. Thanks for the explanations given here. I have always liked firefox and would hate to have to drop it as a browser.
Userlevel 7
Badge +56
Glad to hear the fix worked, and yes, I'll update the thread when we get the extension signed.
Userlevel 7
Badge +56
Yeah Firefox is now warning for non-signed extensions. We're working on getting ours approved by them, but in the meantime you can just re-enable or re-install. If you're having problems getting it working, let us know.
Userlevel 7
I suspect that there is no issue and that the extensiosn are working...it is just a warning but if there is something not quite right then follow Nic's recommendations in the interim.
Userlevel 7
Well, that did not take very long.  Thank you and well done, my Firefox Filter Extension is back 🙂
Userlevel 1
I did the following:
1. Downloaded the new installer
2. Shutdown WR protection
3. uninstalled using tune-up utilities (seems to had worked)
4. re-booted
5. ran installer (did not ask for my keycode), did it's scan.
6. rebooted
7. Firefox still not showing WR password manager.
What hav I done wrong?
Userlevel 1
will try now.